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1 Welcome 
 

Welcome and thank you for choosing the Resultmaker Process Platform. Resultmaker is the premier Business 

Process Management software platform that enables you to build easy-to-use applications for the automation of 

your critical business processes. Whether you’re a process owner, a process consultant, or a system developer, 

you will get basic insights about Resultmaker’s essential features in this guide. 

2 What this guide will teach you 
 

This Getting Started Guide will teach you the basics of working with the Resultmaker Process Designer – 

everything you need to begin creating workflows and streamlining them with proper Quality Assurance via 

prototyping. You will be guided through the following topics: 

 Installing Resultmaker Process Designer on your PC 

 Learning the basics 

 Creating a new workflow from scratch 

 An overview of architecture and its other features 

 



3 Installation 
 

Follow the steps in the table below to install the Resultmaker Process on your PC. This table shows the 

components necessary to run the application, as well as the prerequisites of each step. Click the links in sequence 

to begin your Resultmaker experience. 

 

ST
EP 

WHAT WHY PRE-
REQ
UISI
TE 
STEP 

XP
1
 

VIST
A

2
 

WINDO
WS 7 

WINDOW
S 8 

SIGN
3
 LINK 

 
(CLICK TO INITIATE THE STEP) 

1 MS Win-
dows 

Base operating 
system. 
 
Note: Resultmaker 
Process Designer 
6.0 runs on 
Windows XP, Vista 
and Windows 7 

      [Must be installed on your 
PC] 

2 .Net1.1 Must be on your PC 
to run Resultmaker 
Process Designer – 
also if you have a 
later version of .NET  

 X X    http://www.microsoft.com/d
ownloads/details.aspx?familyi
d=262D25E3-F589-4842-
8157-
034D1E7CF3A3&displaylang=
en  

3 .NET 1.1 
SP1 

Must be on your PC 
to run Resultmaker 
Process Designer– 
also if you have a 
later version of .NET  

2 X X    http://www.microsoft.com/d
ownloads/details.aspx?Family
Id=A8F5654F-088E-40B2-
BBDB-
A83353618B38&displaylang=
en  

4 .NET 2 Must be on your PC 
to run Resultmaker 
Process Designer – 
except if you have 
.NET 3 or later

4
 

 X     http://www.microsoft.com/d
ownloads/details.aspx?familyi
d=0856eacb-4362-4b0d-
8edd-
aab15c5e04f5&displaylang=e
n 

5 .NET 2 SP1 Must be on your PC 
to run Resultmaker 
Process Designer– 
except if you have 
.NET 3 or later 

4 X     http://www.microsoft.com/d
ownloads/details.aspx?Family
ID=0c1b0a88-59e2-4eba-
a70e-
4cd851c5fcc4&DisplayLang=e
n 

6 .NET  3.5 Must be on your PC 
to run Resultmaker 
Process Designer 

 X X  
 

X 

 
 

X 

 http://www.microsoft.com/d
ownloads/details.aspx?familyi
d=333325FD-AE52-4E35-
B531-

                                                                 

1
 Perform these steps, if you have XP on the PC 

2
 Perform these steps, if you have Vista on the PC or XP with .Net3 or .Net3.5 

3
 Perform these steps, if you want to try out solutions with the Danish digital signature 

4
 Vista comes with .Net3. 

http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=262D25E3-F589-4842-8157-034D1E7CF3A3&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=A8F5654F-088E-40B2-BBDB-A83353618B38&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&DisplayLang=en
http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en


508D977D32A6&displaylang=
en 

7 .NET  3.5 
SP1 

Must be on your PC 
to run Resultmaker 
Process Designer 

6 X X  
 

X 

 
 

X 

 http://www.microsoft.com/d
ownloads/details.aspx?familyi
d=AB99342F-5D1A-413D-
8319-
81DA479AB0D7&displaylang=
en 

8 Result 
maker 
Process 
Designer 

Simple and 
powerful workflow 
designer. 
 
With Resultmaker, 
you manage the 
processing of forms 
with multi-party 
users/roles. You 
also oversee when 
to invite the users 
into roles, as well as 
the signing step 
details (multi-party 
transaction design). 
 
The Resultmaker 
Process Designer 
can be evaluated by 
opening content 
e.g. from 
http://demo60.resul
tmaker.com/RMFro
ntend/ 

3, 5 X X    Process Designer 6.0.xxxx.zip 

9 Pointer to 
the  Result 
maker 
server 

Points Resultmaker 
to a demo server. 
demo60.resultmake
r.com. Check 
availability via the 
links. 
 
A proxy server may 
disrupt the 
connection 
between the 
Process Designer 
and the server 

4 X X    http://demo60.resultmaker.c
om/RMFrontend/ 

10 Java VM Must be on the end 
users’ PCs in order 
to run a digital 
signature applet 

 X X  
X 

 
X 

 http://www.java.com  

11 OCES 
certificate 

Must be on the end 
users’ PCs in order 
to execute a Danish 
digital signature. 

8     X http://privat.tdc.dk/digital/  

  

http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.java.com/
http://privat.tdc.dk/digital/


4 Content Elements 
 

Resultmaker makes use of two content elements for execution on the Resultmaker Server: 

1. Workflows. These are workflows that consist of forms, signing steps, business rules and ways to tie 

multiple users together in the workflow, giving them different rights for each step depending on their 

roles. The workflow content model is based on Resultmaker Process Matrix, a unique workflow model 

suited for large and complex business workflows. 

2. Workflow Content - script references and interfaces (such as Forms). Forms are attached to the 

workflow steps. Even if you don’t attach a form to a workflow activity (and the activity is therefore 

undefined regarding its content), the Process Designer will still allow you to test the workflow by 

attaching a default form to the step. 

3. Workflow Content- Rule engine. With Resultmaker, you can have rule engines execute separate steps in 

the business workflow. The outcome of the steps will define the following business workflows, 

involvement of roles, and so on. For example, the outcome of the individual step can be defined by a rule 

engine, which again defines the following workflow.  

 

Figure 1: A Process Consultant’s view of the two content elements of a process: The workflow is on the left side, while one of the 

forms is on the right 

 



 

 

Figure 2: An end-user’s browser view of the same workflow content in Figure 1, showing the run-time view. The selected form is shown on 

the right side of the screen (the “work area” of the application). The workflow menu is shown on the left side.  

 

  



4 An Overview of Resultmaker Architecture 
 

This package contains the Resultmaker Process Designer, a powerful yet easy-to-use process designer tool. In the 

context of the general architecture of Resultmaker, the Process Designer is represented by the red box below:  
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 Figure 3: Process Designer in the general architecture of Resultmaker 

The Resultmaker Process Designer is installed on your local PC. Evaluate the application on Resultmaker’s free 

demo servers (e.g. http://demo60.resultmaker.com).  

Resultmaker designs content in XML format, which may be stored locally on the file system accessible from the PC 

or on the server via the content import web service (this is the default option). The content runs on the 

Resultmaker server; it cannot be executed locally without installing Resultmaker.  

http://demo60.resultmaker.com/


5 Getting started – Opening and Modifying an Existing 

Workflow 
 

Follow these procedures to get started with Resultmaker. 

ATTENTION:  The demo service runs on a server that is publicly available, so your content is visible to others and 
may be modified by others. 

Therefore the project “Funding Application” may be already modified, although Resultmaker from time to time 
resets it as it is described below. 

The Resultmaker Process Designer is pre-configured to connect to demo60.resultmaker.com; this may be updated 
without prior notice. Make sure that your contact in Resultmaker briefs you on which demo server to use. 

5.1 Opening an Existing Workflow from the Demo Server  
 

Step Action 

  
1 To open Resultmaker, click Start > All Programs > Resultmaker Process Platform 6 > Process Designer 

The Resultmaker Process Designer loads. 
  

 

Figure 4: Starting Resultmaker Process Designer 

 
2 Click File > Open > Workflow Designer Project. 

The Open dialog box appears. 
 



 

Figure 5: Opening a Workflow Designer Project 

 
3 Specify the server to work from: 

Type PPGuest in the Username box, PPpassword123 in the Password box and demo60 in the Domain 
box. 

 
The free demo service may change from time to time. The default is “demo60.resultmaker.com”. 
 
4 Click the Find button. 

A list of workflows appears. 
 

5 Click the workflow with the ID “FundingApplication”. 

 
  

Figure 6: Selecting a Project 

6 Click the Select button. 
The workflow “FundingApplication” loads, and the Workflow Designer window and the Properties window 
open. 
 

-end- 



5.2 Renaming a workflow 
 

Step Action 

  
1 In the Workflow Designer window, click the workflow name “Funding Application”. 

The properties of the workflow root level appear in the Properties window. 
 

 
 

 

TIP: If at any time the Properties window disappears (e.g. if accidentally closed), recall it by pressing F4 or 
clicking View > Properties.  

 
2 Rename the workflow: 

In the Properties window (shown in Figure 8 by the red oval), click in the Id property and enter a new 
name. Do the same for the Text property. 
 

 

Figure 7: The Properties Window 

 
  



The Text field contains the name that is shown in the title bar. Modify the field in the Property window to show a 
change in all windows. 
 

 

Figure 8: Renaming the Project 

 
3 Save your change by clicking File > Save or by pressing Ctrl+S. 

 

-end- 

 

Now the workflow can be modified without tampering with the original. However, the forms are referenced from 

the server, so any modification made to a form will still have effect on the original, unless the form is also saved 

under a separate name. 

  



Below is the procedure for changing a form to another name and then attaching the changed form. 

5.3 Renaming a Form 
 

Step Action 

  
1 In the Workflow Designer window, click the label of the form that you want to rename. 

 
2 Click Edit > Open Form or press F7. 

The Form Editor window appears. 
 

 

Figure 9: The Form Editor Window 

 
3 Rename the form: 

In the Properties window (shown by the red oval in Figure 10), click in the Id property and enter a new 
name. Do the same for the Text property. 
 

  



4 While the form window is active (the middle window in Figure 11), click File > Save or press Ctrl+S. 
The form is saved to a different name and also attached to the changed workflow. 
 

 
Figure 10: Renaming the form 

 

-end- 

 

However, it is still the old form with the original name that is attached to the changed workflow. To attach the 

form with the new name, first detach the form with the old name by following the steps in (section 5.4) below, 

and then attach the form with the new name by following the steps in (section 5.5). 

  



The following procedures detail how to change the form attached to a step. 

 

5.4 Detaching a Form Attached to a Step 
 

Step Action 
  

  Right-click the particular step that requires the new form, and then click Detach Form. 
 

-end- 

 

5.5 Attaching a Form to a Step in a Process 
 

Step Action 
  
1 Click on the paper-clip icon on the left of the step. 

The Selection dialog box appears. 
 

2 Specify the server to work from: 
Type demo in the Username and Password boxes. 
 

3 Click the Find button. 
A list of forms appears. 
 

4 Click the name of the new form that is to be attached to the step. 
 

5 Click the Select button. 
The new form is now attached to the step. 
 

-end- 

 

  



6 Creating a New Process and Prototyping 
 

In this chapter you will learn how to create your first workflow and take a look at Resultmaker’s handy Preview 

feature. 

6.1 Prototype the content at any time (Preview – F5) 
You can preview the content on the server through a browser at any time by pressing F5 or clicking Tools > 

Preview. This can be done both from the workflow (when the Workflow Designer window is active) and from the 

form, in which case the form will be shown alone in a one-step workflow containing just itself.  

You will always assume the first role, initially named “Owner” or “Role1”. For workflows with more than one role, 

Resultmaker auto-generates an invitation mechanism, whereby you can specify which users are to play the other 

roles. Simply specify the email address of each role, and a mail will be sent to the other participants. Initially, we 

recommend that you specify your own e-mail address and thereby invite yourself into all roles, so that you can 

see how this method works.  

 

Figure 11: Entering the invitation details for a Role 

The link in the email will require the recipient to log in to get access to the workflow instance.  After creating an 

account by clicking on the link, the new user will be asked to enter a workflow-specific password provided by the 

workflow owner (in this instance, you). The workflow-specific password is specified at the same time that the 

email address is specified. You may leave the password blank, but be sure that the other users are informed if you 



specify another password. This protects against unauthorized access by people who accidentally receive the email 

invitation. 

Figure 12: An example of the email sent to the user with roles in the workflow. 

  



6.2 Creating a New Workflow 
To create a new workflow and a set of forms are required. You may design the workflow part without specifying 

forms; in that case, the Process Designer allocates a default form to all unspecified steps.  

 

Step Action 

  
1 Click File > New > Workflow Designer Project. 

A new Workflow Designer window appears. 

 
Figure 13: Creating a new workflow 

 
  
2 Name your workflow: 

In the Workflow Designer window, click the workflow name “NewWorkflow”. 
The properties of the workflow level appear in the Properties window. 
 

3 In the Properties window, click in the Id property and enter a new name. 
 

NOTE: The name must begin with a letter [a-z][A-Z] and may be followed by any number of letters, digits [0-9], 
hyphens "-", underscores "_" colons ":", and periods "." as long as [:-] is never used. 
 

 
  



4 Save your workflow by clicking File > Save or pressing Ctrl+S. 
The Save Workflow dialog box appears. 

 
 
Figure 14: The Save Workflow dialog box 

 
5 In the Workflow Designer window, click the label of the workflow group (labeled “1.1 New Group”). 

An Add button appears. 
 

6 Click the Add button.  
A list box appears. 
 

7 To add an activity, click one of options in the list. 
 

In this case, select an option that does not attach a form. 
 
  



8 Rename activities and workflow groups: 
In the Workflow Designer window, click the label of the activity or workflow group. Then, in the Properties 
window, click in the Id property and enter a new name. 
 

 

Figure 15: Renaming an activity 

 
Resultmaker requires the "Id" properties to be unique (within their scope). The “Text” properties need not be 
unique. 
 
9 Rename roles: 

In the Workflow Designer window, click the Role tab (on the top-right part, currently named “Owner”). Then, 
in the Properties window, click in the Id property and enter a new name. Do the same for the Text property. 
 

 

Figure 16: Renaming a role 

10 Add a role: 
Click the Add Role icon, which is the person-shaped icon located upper-right corner of the Workflow 
Designer window. Then, in the Properties window, click in the Id property and enter a new name. 
 



 
Figure 17: Adding a new role 

 
11 Assign rights to the roles: 

Click inside the invisible grid that spans the activities and roles (shown by the mouse pointer in Figure 19). 
An icon will appear. 
 

 

Figure 18: Assigning rights to a role 

 
 
 
 
Clicking on the icon will cycle through the various rights possible for each role. They are shown in the table below: 
 

 
Deny access. The user having that role will not see the step, not even in the workflow menu. 
 
 



(No 
icon) 

Read access. The user having that role can see the step in the workflow menu, can select it and 
see the work area as read only fields, but the user can not act in it. 

 
 

 
Write / execute access. The user having that role can execute the step (see and select it in the 

menu), and for forms, fill out the fields of the form referenced by the activity and submit the field 
values. 

 

 
 
12 Insert invitation step: 

Click the Role tab and drag the pointer to the area between two steps. 
Two new steps numbered 1.1.2 and 1.1.3 are inserted. 
 

 

Figure 19: Inserting an invitation activity 

 
  

Drop 

Click and drag 



13 Determine access rights by defining the invitation details:  
Set steps 1.1.2 and 1.1.3 to Write/Execute Access. 

 

Figure 20: Determining access rights 

 
The first invitation sub-activity (1.1.2) will be visible, the other one (1.1.3) is a hidden activity that carries out the 
sending of the invitation e-mail. This other step may be moved to a later point in the workflow (so that the 
definition of who takes the role “Role” happens earlier than when the actual invitation e-mail is sent out). 
 

 
NOTE: Remember that you can view the run-time side of your workflow anytime by pressing F5. 
 

 



 

Figure 21: A run-time view of the invitation step. 

 
14 Insert a signing step: 

In the Workflow Designer window, click the label of the workflow group (named “1.1 New Group”), click 
the Add button, and then click Signing Step. 
 



 
Figure 22: Inserting a signing step 

 

15 Drag the signing step to an appropriate place in the flow (in this case, drag to 1.1.4 as shown in Figure 24). 
 

 

Figure 23: Defining a form step 

 
16  In the DataCollectionActivities field of the Properties window, define the form steps that are to be signed 

(1.1.1 in this case). 
 



A comma separated list is allowed; in this case, the signing step collects data from multiple forms into one (sub-
)transaction. The signing specification is based on a lookup of the data from the form, such that the variable 
names behind the fields of the form become the signing specification, together with the labels of these fields. At 
this time there is no form specified for 1.1.1 and 1.1.5, so the operation is completed when saving the workflow 
after attaching a form to the both steps. 
 
  



17 Determine which role has the right to do the signing. 
 

 

Figure 24: Assigning a role to the signing step 

 
In this case "Role" signs the data that "Myself" has supplied in the form on step 1.1.1. 
 
18 Assign forms to steps 1.1.1 and 1.1.5: 

Do the procedure Attaching a Form to a Step (section 5.5) for steps 1.1.1 and 1.1.5. 
 

19 To see how your workflow will look like in an end-user environment, press F5. 
 

-end- 

 

The transaction specification for the signing step is auto-generated by looking into the form attached to 1.1.1. 

Transactions are committed when all signing steps within the transaction (the outmost grouping in the designer) 

have been completed. 

  



7 Modeling Workflows in Design Workshops 
 

Since Resultmaker makes it easy to prototype a workflow while it is being designed, Resultmaker is extremely 

well-suited for workflow modeling and design workshops. An example of an efficient workshop is described 

below.  

One person stands by the white board drawing the Resultmaker Process Matrix (see Figure 26), and another keys 

the matrix into the Process Designer and shows the result on a projector. 

 

 

Figure 25: The Process Matrix format of the workflow design (on the white board, and also may be documented in Excel to be used in 

documentation and approvals of the design). The right-hand column specifies the forms that constitute each step without going into detail; 

the forms need not be designed in order to prototype the workflow 

 

1. Start with the Activity column -- Add the roles and assign access rights (“E” for execute or write access, 

etc.) 

2. After filling in the activity numbers on the left, list the predecessors for each step.  

3. Describe in words in the last column, what happens on each step. 

4. Add the purposes – the rules that determine if the activity is active in the project.  

5. Mark which steps affect the purposes (“Purpose handling”) 

A B C

Mana-

ger

Rich Hurry Accept

50% 50% 50%

1 Application E Always

1.2 Application E Always Set A, B Application for money, determine A and 

B from data

1.3 Sign E 1.2 Always

2 Process E 1 Always

2.1 Approval 1 E Always Set C Approval

2.2 Approval 2 Deny E 2.1 A And Set C Extra approval step if the applicant is rich

2.3 Express payment E X 2.1, 2.2 B C And Payment step for express payments if in 

a hurry

2.4 Normal payment E X 2.1, 2.2 Not B C And Payment step for normal payments if not 

in a hurry

2.5 Rejection letter E X 2.3, 2.4 Not C And Send a notification if rejection, i.e. no 

payment

2.6 Archive E 2.5 Always Send a notification if rejection, i.e. no 

payment

CEO Case 

Worker

A

ut

o

Rule

Purposes Specifikation / Questionnaire ref.Purpose 

handling

Activity

[bold = 

logic, 

else  seq-

uence]

Pre-dec.Roles / Parties



 

Figure 26: Purpose rules –- compare the green area of Figure 26 (see row 2.3) –- are edited in the Properties window of the 

activity highlighted. Boolean expressions are allowed (“Not”, ”and”, “or”, and parentheses) 

6. Create an “Auto” column to mark steps that are candidates for “Attempt Autocomplete” (steps that will 

be autocompleted, if the form attached to the step already represents known data for each of its 

required fields). 

The forms are not needed to prototype the workflow, but for the “purpose rules” to be prototyped, the forms 

that manage them must be created. See Figure 26. 

7. Create forms as specified 

8. Manage variants through purposes 

a. The Form Editor is used to edit “purposes” 

b. Purposes are set and removed by answers in forms 

c. Attach purposes to steps through purpose rules 



  

Figure 27: Setting purposes depending on answers. 

By default a purpose is false (“removed”), until some form “adds” it (sets it to true). 

  



8 A List of Resultmaker Windows 
Below are the different Resultmaker windows that you will use for creating and editing your workflows. 

1. Workflow Designer. It is the default window and opens with the Ctrl+O shortcut.  

 

 Figure 28: The Workflow Designer window  

  



2. Form editor – opened separately or by pressing F7 in the Workflow Designer. You can preview the 

content of the form on the server through a browser at any time by pressing F5 or clicking Tools > 

Preview. In this case, the form will be shown alone in a one-step workflow containing just itself 

 

 Figure 29: The Form Editor 

 

  



3. Form Layout window 

 

The Form Layout window is accessed by selecting the Page level in the Form Editor and pressing F8 – or 

right clicking the Page level and selecting  

  



4. Properties window – shows properties of the content element highlighted – the workflow, form, or any 

of their sub-elements. 

 

  
  Figure 30: The Properties window 

  



5. Workflow Editor – the full content model editor; opened by pressing Ctrl+I. 

 

Note – do only use the Workflow Editor for workflows developed on older platforms that 6.0. 

Figure 

31: The Workflow Editor 

  



9 Process Platform Component Overview 
This section outlines the all components that the Resultmaker Process Platform consists of. 

Add on Modules and Services

Resultmaker Process Designer Resultmaker Process Server

Process Front End Process Engine

Workflow 
Engine

Workflow 
Presenter

Workflow Designer Script Tool
Data Export 

Definition Tool

Content 
Deployment 

Tools

Process Platform Tools

[Resultmaker Process Platform™]

Standard Supporting Services

Data 
Export 
Service

Document Services
File Store 
Service

Content 
Services

Script Engine

Online 
Payment 
Module

Form Engine

Digital 
Signature

User 
Management
Integration

Form 
Presenter

Process 
Server 

Administration

eGov 
Module 

SAML 2.0

Audit 
Trail 

System
PDF HTML

Form Designer

Signature 
Services

Case 
Administration 

Module

Script Add-
In for Visual 

Studio

Standard 
Supporting 
Services

Process 
Engine 

Automation

CVR 
3.0

CPR Word

 

Figure 32: Resultmaker Process Platform component overview 

Please consult Resultmaker for further information. 

 

 


