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This is a user manual for form design with Resultmaker Process Platform ™. 

It helps the user to understand the concepts of the design tool 

Resultmaker Process Designer at a high level, focusing on the design of 

forms. 

 

If you are looking for design of processes and decisions visit the ‘User Manual for Process Design in 

Resultmaker Process Platform™’ on http://partner.resultmaker.com. 

 

Follow the instructions in text and illustrations, and when you are through, you will know how to build 

a form along with knowing the concepts. 

Targeted version is: Resultmaker Process Platform 6.2 R3 

 

  

http://partner.resultmaker.com/


 

~ 3 / 71 ~ 

Table of Contents 

 

Learning to use Form Designer ............................................................................................................................ 6 

About the program ........................................................................................................................................... 6 

Creating forms and workflows......................................................................................................................... 6 

Form Designer helps you help your users ...................................................................................................... 6 

Digital signatures with Form Designer ............................................................................................................ 6 

What’s in the User Manual ............................................................................................................................... 6 

Help ...................................................................................................................................................................... 7 

To access Help ................................................................................................................................................... 7 

Tutorial and basic information ............................................................................................................................. 8 

What you can do with Form Designer ........................................................................................................... 8 

What you can learn from this chapter .......................................................................................................... 8 

General tips on navigation and shortcuts .................................................................................................... 8 

A: Start up the program and open a sample form ..................................................................................... 9 

Using the sample form as a template ....................................................................................................... 9 

The working areas of Form Designer ........................................................................................................ 10 

The form window ......................................................................................................................................... 10 

The Layout window ..................................................................................................................................... 11 

The Properties window ................................................................................................................................ 13 

The Toolbox ................................................................................................................................................... 13 

B: Save the form with a new name .............................................................................................................. 14 

Where and how to assign a name to a form ......................................................................................... 14 

Saving forms on the Process Platform server .......................................................................................... 14 

C: Modify the form ........................................................................................................................................... 17 

Introduction .................................................................................................................................................. 17 

Viewing your form in a browser ................................................................................................................ 18 

Deleting, moving and resizing elements ................................................................................................. 18 

Adding and placing new elements ......................................................................................................... 19 

Setting the properties for an element ...................................................................................................... 21 

Including or excluding an element from the receipt ........................................................................... 21 

Creating user-friendly layouts .................................................................................................................... 22 

D: Create the workflow for the form ............................................................................................................ 23 

E: Create Notes in the form ............................................................................................................................ 24 

1.1.1 Creating and using Designer Notes ........................................................................................... 25 

The building blocks of Form Designer............................................................................................................... 27 

Elements and properties ................................................................................................................................. 27 



 

~ 4 / 71 ~ 

Elements ............................................................................................................................................................. 27 

Properties ........................................................................................................................................................... 27 

Description .................................................................................................................................................... 29 

Internal ID ...................................................................................................................................................... 29 

Show Icon Placeholder .............................................................................................................................. 29 

Text .................................................................................................................................................................. 30 

Type ................................................................................................................................................................ 31 

Styles ............................................................................................................................................................... 31 

Custom Validation ....................................................................................................................................... 31 

Default Value................................................................................................................................................ 32 

Max Length ................................................................................................................................................... 32 

Read Only ..................................................................................................................................................... 32 

Required ........................................................................................................................................................ 32 

TAB Order ...................................................................................................................................................... 32 

Variable Name ............................................................................................................................................. 33 

Using HTML in Body texts ............................................................................................................................. 33 

Copy Script ID ............................................................................................................................................... 34 

Copy Show Only When ID .......................................................................................................................... 34 

Show Only When .......................................................................................................................................... 34 

Element types ................................................................................................................................................... 35 

Group ............................................................................................................................................................. 35 

Body Text ....................................................................................................................................................... 37 

Heading ......................................................................................................................................................... 38 

Check Box ..................................................................................................................................................... 39 

Drop Down .................................................................................................................................................... 40 

Radio Button ................................................................................................................................................. 42 

Text Area and Text Field ............................................................................................................................. 43 

Both TextArea and TextFields have the possibility of computating inside  the element. This 

possibility is found in the Properties window under ‘Compute Field’ ................................................ 43 

File Element ................................................................................................................................................... 45 

File Attachment ............................................................................................................................................ 47 

Divider ............................................................................................................................................................ 48 

Placeholder Text .......................................................................................................................................... 49 

Annotation .................................................................................................................................................... 49 

Help Text ........................................................................................................................................................ 50 

HTML ............................................................................................................................................................... 51 

Iframe ............................................................................................................................................................. 52 



 

~ 5 / 71 ~ 

Link .................................................................................................................................................................. 53 

Picture ............................................................................................................................................................ 54 

Date Selector Extender .............................................................................................................................. 56 

Description Extender ................................................................................................................................... 57 

Label Extender ............................................................................................................................................. 58 

Modifying layouts in Form Designer .................................................................................................................. 60 

The layout grid .................................................................................................................................................. 60 

The default position for elements ................................................................................................................. 60 

Adding an element ......................................................................................................................................... 60 

Synchronizing the order of elements in the form and layout .................................................................. 60 

Default widths for labels and other texts ..................................................................................................... 62 

Moving an element ......................................................................................................................................... 62 

Changing the size of an element ................................................................................................................. 64 

Deleting an element ....................................................................................................................................... 64 

Acting on multiple elements at the same time ......................................................................................... 64 

In the Layout window ...................................................................................................................................... 64 

In the form window .......................................................................................................................................... 64 

Maximizing user-friendliness................................................................................................................................ 66 

Write in layers .................................................................................................................................................... 66 

Layer 1: Headings structure the page ......................................................................................................... 66 

Layer 2: Questions with answers or statements ease interaction ........................................................... 66 

Layer 3: Help and advice eliminate doubt ................................................................................................ 68 

Help Texts ........................................................................................................................................................... 68 

Descriptions (mouse-over texts) .................................................................................................................... 68 

Explanatory texts (“open” Descriptions) ..................................................................................................... 68 

Remember, NB and Note ............................................................................................................................... 70 

Texts that demystify or reassure..................................................................................................................... 70 

“Must Read” texts ............................................................................................................................................ 70 

Layer 4: Supplementary texts with links to further reading ...................................................................... 70 

 

  



 

~ 6 / 71 ~ 

Learning to use Form Designer 

About the program 

Resultmaker Process Designer™ is the software used for designing and maintaining your business 

processes. It is a part of Resultmaker Process Platform™ – the complete process suite for designing, 

maintaining and executing forms and workflows – the two elements your processes consist of. 

A process consists of a workflow with at least one but often quite a few acitivities. An activity can 

be represented by a form that an end user can fill out. 

An activity could also be signing data, or it could be an activity carried out by a system – for 

instance executing a payment. 

Resultmaker Process Designer™ consists of a Form Designer, a Workflow Designer and an 

Advanced Workflow Designer. 

Resultmaker Process Designer™ is designed to make it possible for non-developers to design and 

maintain forms and workflows. The idea is first of all to make the business more independent of IT, 

and make it possible to maintain their processes and apply changes in the organization without 

costly and timeconsuming IT projects. 

In the following we will focus on how to create forms using Form Designer. 

Creating forms and workflows 

Form Designer is a tool for creating electronic forms (also called  e-forms). With Form Designer, all 

you have to concentrate on is setting up a form. When the form is finished, it can be saved to the 

Process Platform server and attached to one or more workflows. The workflows can then be 

accessed by your users, who fill out the form and complete the workflow online. 

Form Designer helps you help your users 

When you create a form, one of your goals should be to give users all the information they need to 

fill out the form as easily and accurately as possible. This manual includes practical tips and advice 

to optimize the usability of your forms. 

Digital signatures with Form Designer 

Electronic forms created with Form Designer can be set up for digital signature. For more 

information, please contact Resultmaker A/S. 

What’s in the User Manual 

The Form Designer User Manual consists of several parts: 

First the “Tutorial and basic information” section is built up around a short exercise that shows you 

how to create and publish a typical form. At the same time, it introduces many of the basic 

concepts and procedures you will need in Form Designer. 

We highly recommend that you go through the tutorial section before starting to create your own 

forms. 

Then the “The building blocks of Form Designer” section will systematically explain the various 

design elements and properties and how to use them. 

Later in the “Creating layouts in Form Designer” section it will be explained how to place and 

modify elements on the page to create the layout you want. 
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Finally the “Maximizing user-friendliness” section contains a number of useful tips for building user-

friendly layouts and writing well-functioning texts. Following its advice will help ensure that users find 

your workflows easy to understand and deal with. 

Help 

Form Designer contains an extensive online Help file. 

Note that the file also includes information on topics that are not part of the Form Designer level of 

Process Platform. 

To access Help 
- Either: Click on an item in the form window and press F1. This will take you directly to the Help 

page for the selected item. 

- Or: Select Contents, Index or Search from the Help menu and navigate to the desired topic. 

 

Figur 1: Form Designer has an extensive online Help file. To open it, check that the form window is 

active and press F1. Or select Contents, Index or Search from the Help menu. 
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Tutorial and basic information 

What you can do with Form Designer 

Form Designer is part of Process Designer, which is Process Platform’s design tool. In its full form, 

Process Designer can be used to build both simple and complicated forms and workflows. 

What you can learn from this chapter 

This chapter introduces you to many of the basic concepts of eForm -Designer. At the same time, it 

takes you through the following easy operations that demonstrate how to create a fully functional 

workflow: 

A. Open one of the sample forms supplied with the program. 

B. Save the form under a different name. 

C. Modify the form. 

D. Create a workflow that goes with corresponding form. 

To move quickly through the tutorial, follow the instructions marked DO THIS. 

General tips on navigation and shortcuts 

 Navigation in Form Designer follows Microsoft Windows standards. 

 The availability of certain commands in the menus at the top of the screen may depend on 

which window is active. Certain functions can only be carried out when the form window is 

the active window. 

 Right-clicking on an element in the form window will display commands that are relevant for 

that element. Some commands are only available this way. 

 Some useful shortcuts are: 

-  Ctrl+shift+N: Creates a new, blank form. 

-  Ctrl+shift+O: Lets you open an existing form. 

-  Ctrl+S: Saves the form you are working on (provided the  

 form window is active). 

-  Ctrl+Z: Undo. 

-  Ctrl+Y: Redo. 
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Form Designer includes a few sample forms that you can use as a basis for exploring the program or 

creating your own e-forms.  

To open a sample form select Open > Form in the File menu.  

 

 
Select Open from file to browse your system for the Sample form that came with the software.  

 

 

 

Select Sample form named: SamplevariousElements  

A: Start up the program and open a sample form 

Using the sample form as a template 

Form Designer includes some sample forms that are pre-designed with content and layout. You 

can use these as a basis for getting to know the program (as we will do in this tutorial) or as 

templates that you can modify for quickly building your own solutions. 

DO THIS: Start the Process Designer from the MS Windows’ Start Menu. Select File > Open > Form in 

the File menu. Select Open from file to browse your system for the Sample form that came with the 

software. Select Sample form named: SampleVariousElements 
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To open Layout window for a given page, right-click on the page in the form window and select Layout

Form Designer has three working windows (form, Layout, and Properties) plus a Toolbox. 

The working areas of Form Designer 

The Form Designer interface includes a Toolbox as well as three windows you will be working in: 

 Form. 

 Layout. 

 Properties. 

 

DO THIS: Open the form, Layout and Properties windows as explained below and place all three 

windows where you want them on the screen.  

 A window can be moved or resized by dragging it with the mouse as in other Windows 

programs. 

 A suggested screen setup is to put the form window at top left, the Properties window 

below it and the Layout window filling up the right-hand side of the screen. 

The form window 

 To open the form window, select New (for a new form) or Open (to open an existing form) 

from the File menu. 

 The form window is your main working window and represents the project you are working 

on. Closing the form window corresponds to closing a document in other Windows 

programs. 

 The name of the form will appear as the title of the window. 

 The form window displays the contents of the current form as a hierarchical tree structure. A 

form can include one or more pages. Howeveer it is adviced to use new forms instead of 

pages, since pages are not visible for the end-user in the overall table of steps. Pages will 

not be described in more details. 

Layout window 

Shows how the elements of a given 

page will be arranged, and lets you 

change the layout. 

 

 

Properties window 

Displays the properties of 

the element you are 

working with. 

 

 

Toolbox 

Contain

s the 

design 

element

s for 

drag & 

drop. 

 

 

Form window 

Displays the elements as 

a hierarchy. 
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 To unfold a form hierarchy and view its contents, click on the “+” symbols. To collapse a 

node in the hierarchy, click on its “–” symbol. 

 In the form window you can add, move and delete elements (this can also be done in the 

Layout window). 

 The form window must be active for you to be able to save the form. Click anywhere in the 

window to activate it. Note that a star is displayed after the form name at the top of the 

window if you have made changes since the last time you saved the form. 

 Right-clicking on an element in the form window opens a menu that may contain some 

commands not found elsewhere. If you get stuck when using Form Designer, try right-

clicking. Or use F1 to access the online Help file.  

 

Unsaved changes are indicated by a star next to the form name at the top of the form window. If no star is 

displayed, the latest changes have been saved. 

If the name of the form is long, you may need to drag the side of the window to view the star 

The Layout window 

 To open the Layout window for a given page/form, right-click on the page name in the form 

window and select Layout. 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

To open the Layout window for a page,  

right-click on the page name and select Layout or press F8. 
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Page content 

Element 

Page name 
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 You can add elements by dragging them -directly into the Layout window from the Toolbox 

(or by right-clicking in the form window). 

 In the Layout window, you can use the mouse to resize elements and move them around to 

create the layout you want. 

 You can delete an element by clicking on it in the Layout window and pressing Delete. 

 For certain elements (Text Field, Text Area, Check Box, Drop Down, Radio Button og Help Text), the 

Layout window shows both the element itself and its label. The -label’s name corresponds to 

the Text property in the element’s Properties window. If the element is a Text Field or Text 

Area, its name corresponds to the Internal ID property. 

 To act on an element and its label together, click on the element itself; to act on the label 

only, click on the label. 

 The Layout window has a grid that elements snap to when you move them. This ensures that 

everything is kept in alignment. 

The Properties window 

 To open the Properties window, right-click on any element in the form window and select 

Properties. Or click anywhere in the form window and press F4.  

 Each element in a form has its own properties. When you click on an -element in the form or 

Layout window, the Properties window displays the properties for that element, allowing you 

to review or edit them. 

 If you click on a different element, the Properties window will automatically change to 

display that element’s properties. 

 For an explanation of the various properties, see “Building Blocks of Form Designer.” 

The Toolbox 

To open the Toolbox, select Toolbox from the View menu or press F10. 

 From the Toolbox, you can drag new elements into the Layout window and place them 

wherever you want. 

 For an explanation of the various elements, see “Building Blocks of Form Designer.” NOTE: A 

few elements are not available at the Form Designer level of Process Platform and are 

therefore not described in this manual. 
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B: Save the form with a new name 

Each time you start designing a new form, start by giving it a name and saving it on your Process 

Platform server. This will help you avoid accidentally overwriting an existing form with new content. 

Where and how to assign a name to a form 

 When you look for a saved form on your Process Platform server, its name will be the same 

as the text you entered for the Internal ID property in the form’s Properties window. 

 Spaces and certain special characters are not allowed in the text of an -Internal ID. If you 

enter a name that does not conform to the requirements for this property, a dialogue box 

will appear to help you. 

 When you view the same form in a browser, the name displayed will be the same as the text 

you entered for the Text property in the form’s Properties window. 

 

 

 

Saving forms on the Process Platform server  

When you save a form, you will be asked whether you want to save it on a Server (default choice) 

or as a File. 

 If you select File, you will be saving only a static representation of the form, not a fully 

functional e-form that users can fill out. File can, however, be an appropriate choice for 

backup purposes or if you, for example, want to send the form to a collaborator who also 

has Process Platform. 

 If you select Server, you save a functional e-form/workflow that can be  displayed in an 

Internet browser and used for entering data. 

 User name and password: Since Process Designer is directly integrated with the server box 

supplied with Form Designer, you do not need to enter a user name or password to save 

forms on the box.  

 When you use the Save As feature, it is possible to change the name/Internal ID of the form. 

This happens on the Save Form dialog. 

 

Select the highest level of the 

form to change the name in 

the Property window. The text 

you enter for the Internal ID 

property becomes the name 

of your form. 
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DO THIS:  

 To give your form a new name, open the form’s Properties window by right clicking on the top 

element of the hierarchy in the form window and selecting Properties. Then enter the 

desired name for the Internal ID property. 

NOTE that the new form name must be entered in the Properties window. You will not be 

able to enter it in the Save As... dialogue. 

 To save the form, first check that the form window is active (if not, click on it). Then select File 

> Save As..., check that Server is activated and that the Server Name is ocbox (or the name 

of your Process Platform server) and click OK.  

 

  

Select Save as in the file 

menu to save your form on 

the server to make it 

available for others.  The 

settings for the server are 

typed in by default. Just hit 

Save. 
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The Layout window schematically shows the layout of the page. Compare this view of the Purchaser 

page to the view in the form window (above left).  

Unfold the hierarchy in the form window 

to view the elements of each page. 

Note that each element type has its own 

icon (see the Toolbox overview under 

“The Building Blocks of eForm Designer”). 

 

For this exercise, open the Application 

page. 

Page 

Page 
Heading 

Heading 

 

Group 

Body Text 

Text Field 

Page 

Page 

 

Heading 

Heading 

 

 

 

 

Group 

Group 

 

Body Text 

Body Text Text Field 

Text Field 
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C: Modify the form 

Introduction 

SampleVariousElements consists of one page named Application and  three main groups: 

 Company making the application 

 Purchaser 

 Terms and conditions 

DO THIS: To open the Layout window for the Application page, right-click on the page’s name in the 

form window and select Layout. 

The following pages will show you how to carry out some basic operations for modifying a page 

layout. 

 

 

To view your form as it will 

look in the browser, right-

click on the question-naire’s 

name and select Preview or 

F5. 
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In the browser, the Purchaser group of your form will look something like this. 

Viewing your form in a browser 

As you work with the form, you will probably want to check how your modifications will look. For this, 

you can use the Preview function, which shows how the form will appear to end users when 

displayed in a web browser.  

DO THIS: 

 To preview your form: 

- Save the form as described above under “Save the form with a new name” (you will still be 

able to use Undo (Ctrl+Z) afterwards to undo any changes, if necessary). 

- Right-click on the form’s name at the top of the hierarchy in the form window and select 

Preview, or click anywhere in the form window and press F5.  

 

 

Deleting, moving and resizing elements 

 To delete an element in the Layout window, click on it and press the Delete key.  

 

 To move an element in the Layout window, click on the element and: 

- Either: Drag the element with the mouse. 

- Or: Press the relevant arrow keys on your keyboard to move the element in the desired 

direction. 

- If the element has a label, make sure you click on the element itself. Otherwise, you will move 

only the label. 

  

 

 To change the size of an element in the Layout window, click on the element and: 

- Either: Drag the square white -handles that -appear in the frame around it. 
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- Or: Hold down the shift key and press the relevant arrow keys on your keyboard. 

 

 

 

DO THIS in the Layout window: 

 To practice deleting elements, click on the Middle name field and press the Delete key. 

 To practice moving elements, click on the Amount in dollars field and move it farther to the 

right by dragging it and by using the arrow keys. 

 To practice resizing elements, click on an element and resize it by dragging its -handles and 

by holding down shift and using the arrow keys. 

  

Adding and placing new elements 

There are two ways to add elements in Form Designer. 

DO THIS: To practice adding elements: 

 Drag a Heading element from the Toolbox into the Layout window (if the  

Toolbox is not open, open it by pressing F10). 

 Now add a text field by right-clicking on the Purchaser group in the form window and 

selecting Add > Text Field. 

 

 To add an element to a page: 

- Either: Drag it from the toolbox to the desired position in the Layout window. The new element 

will also appear in the form hierarchy, at the end of the group you dragged it to. You may 

therefore have to manually change its position afterwards (see below). 
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- Or: Right-click on a page or group in the form window and select- Add and the desired 

element type. The new element will appear at the end of the active page or group in the 

hierarchy and at the left-hand edge of the Layout window. The left-hand position was chosen 

as the default because it will always produce an acceptable layout. If desired, you can 

manually move the element to a different position on the page, but the default position is 

recommended for most purposes. 

 

 To change the position of an element in the form hierarchy within its page or group, click on 

it and use the following shortcuts: 

- Up: Ctrl+U. 

- Down: Ctrl+D. 

- Repeated use of these functions will “circulate” the element within the page or group (i.e., if 

you reach the top, the next position will be the bottom, and vice versa).  

 

 To move an element in the form hierarchy to a different  group, drag it until the cursor is over 

the icon or name of the desired group. It will be added to the end of that group. 

 

At first, you may find it easiest to add elements by dragging them in from the Toolbox. However, 

once you are more familiar with Form Designer, you will probably find it more efficient to add most 

elements via the form window, where you have immediate control of their position in the hierarchy. 

Note that the place the elements have in the form tree structure is not the same as they will have in 

the layout manager. This gives the possibilities of different structures for receipts and layouts.  
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Setting the properties for an element 

In the Properties window, you can change some settings related to the way an -element is 

presented to users. For example: 

 You can change the name shown for the element. 

 You can define what type of information the user must enter (-numeric, date, text, e-mail or 

password). 

 

 

 

 To view and/or change an element’s properties, open the Properties window by right-

clicking on the element and selecting Properties. Then enter the desired content for the 

property. 

- NOTE: The Internal ID property is generated automatically by the program and should not 

normally be changed. Advanced user can howevere have some advantages of changing it, 

if they need to call it in JS.  

DO THIS: To practice changing properties: 

 Open the Properties window for your new Text Field or Heading element and type the 

desired name for the element into the Text property.  

 For the Text Field, click on the Type property and select Date from the pulldown menu. 

 

 

Including or excluding an element from the receipt 

Form Designer automatically assigns a Variable Name to each element in a form. The program uses 

these names when it generates “form data,” which is involved in displaying receipts to the user. 

The Variable Name is particularly important for any -element (Text Area, Text Field, Drop Down, 

Radio Button and Check Box) that can contain data entered by end users, since you will normally 

For a Text Field, the Type 

property lets you specify 

the type of information 

that must be entered by 

the user. 
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want these data to be shown in the receipt. If desired, you can change the automatically 

generated Variable Name to a name of your own choosing. 

 To change an element’s Variable Name, type the desired name into the Variable Name 

property in the element’s Properties window. 

o If your workflow must conform to a given XML standard, use the naming conventions 

realated to that standard. 

o A good practice in any case is to avoid using spaces and special characters and to 

start each new word with a capital letter if the name consists of more than one word 

(for example: -CurrentMailingAddress). 

 To prevent an element from being shown in the receipt, leave its Variable Name property 

blank  

Creating user-friendly layouts 

Form Designer intentionally limits the layout possibilities available to designers, in order to ensure 

that the final product is consistent and user-friendly. 

For example, when you add a new element via the form window, it is always placed at the left edge 

of the layout. Labels are placed directly above their text fields, and radio buttons and check boxes 

are automatically aligned with each other on the page. 

You will also discover that, when you add elements by right-clicking in the form window, their 

vertical placement in the Layout window is automatically optimized to create a harmonious page 

in the browser. 

You can freely change the layout of your forms, but If you stick close to the default settings in Form 

Designer, your forms will be easy and efficient for users to navigate in. 

For additional tips on optimizing the usability of your electronic forms, see “Maximizing User-

friendliness.” 
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D: Create the workflow for the form 

When you are finished editing the content and layout of your form, you are ready to put it into a 

workflow. The workflow is the Container for your forms.  

DO THIS: To create a Workflow to add your form to: 

 Either: Select New >Workflow  from the File menu. 

 Or: press Ctrl + N 

 

 

 

 

 

 

 

 

 

 

 

Start off by naming your workflow and select the server you want to save it to. This gives you the 

option of using the preview function directly from the workflow.  This is done the same way as forms, 

in the property window. For more details see the “Getting started with Process Design” section of 

the “User Manual for Process Design in Resultmaker Process Platform” manual – located on the 

“Resultmaker Partner Site”. 

Now it is possible to attach the form you have created to the workflow. This is done by adding the 

form to the first form activity step.  

DO THIS: To attach a Form to the Workflow: 

 Either: click the Paperclip and search and select the desired form from the server 

 Or: right-click the step and choose Attach Form 

 

The whole workflow can now be previewed in the browser by pressing F5 or by selecting  Preview in 

the View menu 

The workflow will look like 

this when it is created 

 

 

http://lrd.to/7unsJT273i
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In the browser, your completed tutorial e-form will look something like this. 

 

E: Create Notes in the form 

The Process Platform lets you keep track of your notes regarding your work in the Forms and the 

Workflow, this can be usefull when returning to a workflow, if more are working on the same 

workflow, etc.  See figure below. 

DO THIS: To add Designer Notes to your form: 

 Either: right-click anywhere on the form and choose ‘Designer Notes’  

 Or: when form window is active press Ctrl+ T 

 

This will open a separate window, the Designer Notes Window.  
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This section will describes how to use the workflow.  

1.1.1 Creating and using Designer Notes 

It is possible to add different markdown elements to the notes: headings, bullets, images, etc.  

To start writing notes you click the pencil in the bottom right corner.  

 

This will give  you a page for you to add your notes.  In the bottom of that page there are tips for 

how to style and write the notes with markdown. 

 

 

Designer Notes Window, 

that displays the nortes 

you have written.  

Designer Notes page 

that lets you write your 

notes  

Tips for using Markdown 

in the Designer Notes 

Window  
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To see the notes you have created press the view document symbol in the bottom right of the 

window.   

 

Now you can write whatever notes you might find relevant for the workflow, a small test is shown 

below to give another example of  how to use it.  

  

 

It is also possible to add designer notes for each workflow, this is shown in the “User Manual for 

Process Design”.  
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The building blocks of Form Designer 

Elements and properties 

In Form Designer, you build up a form from elements. Each element has certain properties. 

Elements 

You can add elements to a form in two ways: 

 by dragging them into the Layout window from the Toolbox. 

 by selecting them from the right-click menu in the questionnaire window. 

For the most part, the two methods are equivalent. As you become more familiar with Form 

Designer, you will learn what works best for you in various situations.  

The individual elements are explained below under “Element types.” Some advanced elements are 

not included at the eForms level of Process Platform. These are grayed out in the Toolbox illustration 

and are not described here.  

Each type of element has its own icon that is used in the Toolbox and form window to help you 

recognize the various element types. 

Properties 

When you click on an element in the form or Layout window, you make it active, and the element’s 

properties are displayed in the Properties window (assuming it is open). If you then click on another 

element, the Properties window will change to show that element’s properties.  

Depending on the element type selected, the Properties window will display different items. Some 

properties apply to all element types, while others are only relevant for one or a few types of 

elements.  
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The Properties window for a Text Field. Some elements have fewer or other properties than the ones shown 

here 

 

For some properties, the defaut values do not need to be changed, while for others, you will need 

to enter the values or content you want.  

If a property has predefined values, clicking on it in the Properties window will display the icon for a 

pull down menu for selecting the desired value. 

In some cases, clicking on a property will display the icon “...”. Clicking on this opens a window in 

which you can select one or more values (for example, the Styles list) or enter free text (for 

example, the HTML editor). 

This section gives a brief explanation of the properties you will need to address, concentrating 

mainly on properties that are relevant for a number of different elements.  
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Description 

The Description property creates a help text that can be displayed either as a mouse-over (the 

default mode) or as an integral part of the page. In default mode, if you enter text for the 

Description property, an information icon is displayed next to the element. When the user places 

the cursor over the icon, the text you entered is displayed.  

If you want the text to be displayed directly on the page, set Show Icons to False, drag a 

Description Extender into the Layout window from the Toolbox and use its -Attach to element 

property to attach it to the relevant element. 

If you need to write a long text, it can be an advantage to write it in Notepad or another simple 

text editor and then copy and paste it into the Description property. Similarly, to work with a long 

text that is already in the Properties window, you can use Ctrl+A to select the whole text, then copy it 

to Notepad, edit it and paste it in again. 

Internal ID 

An element’s Internal ID is generated automatically. However it is good practice to change the 

name of the Internal ID, so that it represents the field.  

The value of the Internal ID must begin with a letter [a-z] or [A-Z] and may be followed by any 

number of letters, digits [0-9], hyphens "-", underscores "_" colons ":", and periods "." as long as [:-] is 

never used. 

 

Show Icon Placeholder 

Show Icon Placeholder should normally be set to True. This will reserve space in the layout to 

display: 

 Required: the symbol (*) indicates that a field must be filled out. 

 Description: the information icon that indicates that a mouse-over help text is available. 

 
A star next to an element shows users that an answer is Required. 

 

If Show Icons is set to False the space is used for the field to be broader, so that the screen space 

can be better utilized. However as seen below, the required field overrules the Show Icon 

Placeholder settings.  

 

 

Figure 1 No description, Required=Required/ConditionrRequired and Show Icons Placeholder=false 
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Figure 2 No Description, Required=NotRequired and Show Icons Placeholder=false 

 

Note that there are three options under ‘Required’: NotRequired, ConditionalRequired and 

Required. 

NotRequired and Required is selfexplanatory, but ConditionalRequired needs a short explanation. 

Conditionally goes together with the feature where it is possible to hide and show form elements. 

An element that can be hidden should not have the Required setting, but instead the 

ConditionallyRequired. In effect in means that if such an element is presented the Required 

validation will be enforced, and if it is hidden it is not enforced. 

Text 

The text you enter here is displayed to the user. This property is used for entering the actual content 

of many elements, such as a Body Text, Heading, Text Field, Text Area, the name of a Group,  and 

the individual answers for Check Boxes, Drop Down Options and Radio Button Options. 

  
 

If you need to write a long text, it can be an advantage to write it in Notepad or another simple 

text editor and then copy and paste it into the Text property. Similarly, to work with a long text that 

 The Style Selector lets you change the 

way some text elements appear 

typographically in the browser. 

Normally, however, the 

predetermined default styles will give 

you the best results. 
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is already in the Properties window, you can use Ctrl+A to select the whole text, then copy it to 

Notepad, edit it and paste it in again. 

Type 

For a Text Field, the Type property defines how the user’s input will be displayed. If nothing is 

specifically chosen, the data type Text is used by default. 

 

 

The following data types are possible: 

 Text is the default mode and displays regular text. There are no validations on this element 

type. 

 Integer display and validates whole numbers.  

 Decimal displays the entry in the correct local decimal format and validates for legal input. 

 Date displays the entry in the correct local date format and validates for legal date input. 

 Email displays the entry as an e-mail address and validates for legal date input. 

 Password changes the characters entered to ”*****”. 

 DeprecatedNumber, this type should only be used for backwards compatibility, but should 

preferable be change to Integer or Currency. 

 Percentage displays the entry in the correct local format and validates for legal input. 

 Currency displays the entry in the correct local format and validates for legal input. 

 Permille displays the entry in the correct local format and validates for legal input. 

Styles 

Each element in Form Designer is preformatted in a default style that has been specifically selected 

as the most functional typography for that type of item. You will therefore generally not need to 

change the Styles property, but if you do, you can access a list of predefined styles. 

For some elements, such as a Heading or Body Text, the style affects the way the element itself is 

displayed. For a Text Field or Text Area, the style affects the appearance of the information the user 

types in. For these elements, you can therefore also change the style of the element’s label (its 

“heading,” taken from the Text property) and Description, but we recommend that you stick to the 

default styles, as they will be the easiest to read.  

To change an element’s style, click on the Styles property, click on the “...” symbol and activate the 

desired style or styles in the Style Selector that appears. 

Custom Validation 

For a Text Field, you can use the Validation property to select one of a number of standard tests that 

can be performed on the data to ensure that they are in the correct format. If the data does not 

validate, the user will be shown an error message and will be asked to re-enter the data. 

 The Type property lets you specify what 

kind of data must be entered in a Text 

Field and automatically formats the 

entered data correctly. 
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The Custom Validation property lets you select a standard validation test to ensure that the data entered in 

a Text Field are properly formatted. If not, the user is alerted. 

 

Default Value 

Default Value can be used to display a standard value or text for an element. For example, you 

could pre-fill a Text Field or Text Area with the most likely text. 

If the element is a Radio Button or Check Box, you can use Default Value to preactivate a given 

answer. Click on the Default Value property and use the drop down menu to select the answer. For 

a Radio Button, the possible answers are represented by the Internal ID’s of the Options. For a 

Check Box, true means “checked.” 

Max Length  

Max Length determines the maximum number of characters that can be entered in a field. The 

default value for a Text Field is 255 and for a Text Area, it is 32767. 

If you set a maximum number of characters for an answer (especially if it is small), you should write 

a Body Text to alert users to the limitation. 

Read Only 

If Read Only is activated, the user cannot enter anything in the field or change any preset default 

values.  

Required 

You can use Required to determine whether a question must be replied to. The require-ment will be 

indicated in the browser by a star next to the element. If the user clicks Continue without having 

replied to the element, a message will be displayed that reminds him or her to reply. 

TAB Order 

The TAB Order value determines where the current element is placed in the TAB Order on the page. 

The values can be specified from 0 to n. If you start changing the TAB order it is good practice to 

change it for all elements on the page. 
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Figur 2 Tab Order property 

Variable Name 

Any element that contains data should have a Variable Name, because this property is used to 

return the data to the user in the receipt. Form Designer assigns a Variable Name automatically, but 

you can change the name if you want to. 

Note that it if two elements in a form need to have the same data entered (for example, if the name or 

identification number of a person or company needs to be entered in more than one place), you can 

get Process Platform to fill out the second occurence of the data automatically by giving the second 

element the same Variable Name as the first one. 

Read more about variable names under “Tutorial and basic information”, “C: Modify the form”, 

“Including or excluding an element from the receipt”. 

Using HTML in Body texts 

Form Designer lets you use a few basic HTML tags to highlight text as bold or italic, insert a line break 

or insert a link. If you need other HTML tags, for example to create a bulleted or numbered list, use an 

HTML element. 

The following tags can be used directly in the texts you write for a bodytext or any element’s Text 

and Description properties: 

<b> bold 

<i> italic 

<br> break (forced line break) 

<a> anchor (link) 

  

HTML codes in a Body Text element. It is shown by clicking the ‘…’ button in the textfield in the properties of 

the body text element.  

 
The same Body Text displayed in the browser. 
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Copy Script ID 

This is the ID of the entire script ID for the given element. This is used for… 

To copy script Id right click on the element which Id you want to copy and select ‘Copy Script Id’ 

see figure below. 

                    

‘Copy Script Id’ by right clicking      ‘Copy Show Only When ID’ by right clicking 

Copy Show Only When ID 

This is the Id name needed for using the ‘Show only When’ function explained below. It removes the 

unnecessary path of the ID. This is found in the same way as the ‘Copy Script ID’. See figure above 

 

Show Only When 

The Show Only When feature gives you the possibility of show and hide elements in the forms 

depending on a previous answer from other question elements etc. without having to create a 

JavaScript. An example of this could be if an answer generates its own question, or group of 

questions that are shown or hidden depending on the users previous answer. It is found in the 

Properties window for the specific element. 

 

Show only when, is in the buttom of almost all elements. 

Example of  ‘Show Only When’ were the next question is shown only if the user answers yes in the 

previous RadioButton Question 

1. Create a new form by left-clicck on  the file and selecting New > Form or Ctrl + Shift+ N 

2. Create the RadioButton by right clicking on the element or the page and choose Add > 

Radiobutton or Add below > RadioButton 
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3. Create a TextField below by right clicking on the RadioButton  element and select  Add 

below > TextField 

4. Choose  which option in the RadioButton should show the TextField and which option should 

hide the TextField, find the ID of the option that should show the TextField. Here we choose 

Option1 ( see fig. below)  

5. Right-click on the RadioButton and select ‘Copy Show Only When ID’ 

6. Open TextField and paste the ‘Show Only when ID’ into the ‘Show Only When’ property in 

the buttom of the TextField properties window. Finish by indicating what Option it is 

depending on, by  adding == and the Id of that Option, see fig below. 

 

 

 

 

 

Element types 

This section systematically explains the element types that are available in Form Designer. They are 

presented in the same order you will find them in the Toolbox. 

The examples shown are taken from the supplied sample forms. 

Group 

When you are laying out a page, it is often a good idea to take elements that logically belong 

together and gather them into a group. 

 Grouped elements help users get an overview of the layout, especially if you use visual effects like 

a border (with or without the group’s name) and/or a gray background. Grouped elements also 

make your layout work easier, because some operations (moving, styling, etc.) can be carried out 

on the group as a whole instead of each individual element. 

Find the ID of the 

option that you 

which to show the 

TextField 

In ‘Show Only 

When’ property of 

the TextField add 

the Show Only 

When ID’ equal to 

the option ID. 
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To create a group 

7. Drag a Group from the Toolbox into the Layout window, or right-click on the page name in 

the form window and select Add > Group. 

8. Insert the desired elements by dragging them from the Toolbox or by right-clicking on the 

group name in the form window and selecting Add > [element type]. 

» In the form window, you can also use the mouse to drag existing elements 

into or out of a  group. Drag the element until the cursor is positioned over 

the icon for the group or the page you want the element to become part of 

and release the mouse button. 

» In the Layout window, make sure you drag elements into the space defined 

by the group’s border if you want them to become part of the group. 

9. If you want the browser to display the group’s name, type the desired text into the Text 

property in the group’s Properties window and set the Show Border property to True. Both of 

these conditions must be fulfilled for a name to be displayed. 

 

To create a border around a Group, set its Show Border property to True.  

 

 

To change the way a group appears in the browser 

1. Border: To create a border around the group, set its Show Border property to True. If the 

group has a name (in other words, if its Text property is not blank), the name will 

automatically be set into the top line of the border. 

  

If the group has a name, it is automatically included at the top of the border. If you don’t want 

to display a name, leave the group’s Text property blank. 

 

2. Gray background: To create a light gray background for the group, click on its Styles 

property, click on “...” , activate Background (default) and click on OK. 
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A Group with a  background(default)  as it would appear in the browser. 

 

3. No graphics: By default, groups are displayed in the browser without a border (because the 

Show Border property is set to False), without a gray background (because the Background 

(default) style is not activated), and without the name of the group. 

4. NOTE: To help you get an overview of your layout, the Layout window shows each group 

with a border and (if there is one) the name of the group, whether or not you ask for a 

visible border in the browser. 

 

 

Body Text 

A Body Text can be placed anywhere on the page and is not directly connected to any other 

element. This element is most commonly used for writing explanatory texts. 

You can determine how a Body Text will be displayed by using the Styles property. For example, 

you can use the Emphasize style to create a heading-like text or the Must Read Text style for an 

important warning that must not be overlooked. To help you create forms with a unified and 

consistent appearance, Form Designer offers only a limited number of different styles.  

 

 
Type the desired text for a Body Text element into its Text property. 

 

 
This is how the Body Text would appear in the browser. 
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Note that any styles you apply will only be visible in the browser, not in eForm -Designer’s Layout 

window.  

To create a Body Text 

1. Drag a Body Text from the Toolbox into the Layout window, or  right-click on the page name 

in the form window and select Add > Body Text. 

2. In the Properties window, type the desired text into the Text property. 

To create multiple paragraphs in a Body Text 

3. Either: Use the HTML tag <br> (forced line break) to start a new paragraph. This is only 

possible when choosing a HTML element, not with a body text element. 

4. Or: Use a separate Body Text element for each desired paragraph. 

5. Note that a Body Text has a maximum length of 500 characters, so if you exceed this limit, it 

is necessary to use the second approach with separate Body Test elements, each with less 

that 500 characters 

To change the style of a Body Text 

1. Click on the Styles property, click on “...” , activate the desired style and click on OK. 

 

Heading 

Headings help structure the page and give users an overview. They appear in bold type and a 

larger font size in the browser, but in ordinary type in Form Designer’s Layout window. 

In Form Designer, headings that are created as a Heading element are also included in the 

automatically generated receipt. This means that there are cases where you may prefer to use 

another method of creating what looks like a heading on the page. 

 

 
In the Layout window, a Heading is displayed without formatting. 

 

The same Heading as it would appear in the browser. 

To create a Heading that will appear in the receipt 
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1. Drag a Heading from the Toolbox into the Layout window, or right-click on the page name 

in the form window and select Add > Heading. 

2. In the Properties window, type the desired text into the Text property. 

To create a Heading that will not appear in the receipt 

1. Drag a Body Text from the Toolbox into the Layout window, or right-click on the page name 

in the form window and select Add > Body Text. 

2. In the Properties window, type the desired text into the Text property. 

3. Click on the Styles property, click on “...”, activate either Emphasize or -Heading 2 and click 

on OK.  

- Heading 2 results in a slightly smaller font size than Emphasize, which in turn is slightly smaller 

than a Heading element would be. 

Check Box 

A Check Box is a statement displayed together with a small box that the user can click on to create 

a check mark.  

Check boxes are typically placed after a question, such as, “Do you agree to the terms stated 

above?” or “Does the company import any of the following items?” For each possible answer, you 

create a check box with an accompanying text. 

With check boxes, the answers are not mutually exclusive: the user can mark any or all of the 

relevant answers. If you need a set of mutually exclusive answers, use radio buttons or a drop down 

menu. 

 

 

 

 

 

Check Boxes as they are displayed in the Layout window. Note that the element itself is the small square 

box, while the text next to it is its label (defined by the Check Box’s Text property. 

 

 

The same set of Check Boxes as they would appear in the browser. 

 

Body Text or Heading 

 

Five individually created 

Check Boxes 
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In the receipt, a user’s answer to a check box is taken from the ID property of the Checked or Unchecked 

option.You may therefore wish to change the ID texts from their default values of “Yes” and “No” to 

expressions that are meaningful in context.  

To create a question with one or more non-mutually exclusive answers 

1. Create the question by dragging a Heading or Body Text from the Toolbox into the Layout 

window or by right-clicking on the page name in the form window and selecting Add > 

[element type]. 

2. Drag a Check Box from the Toolbox into the Layout window, or right-click on the page 

name in the form window and select Add > Check Box. 

3. For the Text property in the Properties window, type in the answer that you want the check 

box to represent. This is the text that will appear next to the check box. 

4. Repeat steps 2 and 3 for each additional check box needed. 

 

What do the “Checked” and “Unchecked” options mean? 

Under each Check Box element, the form hierarchy automatically generates a Checked option and 

an Unchecked option. These represent the two possible states the check box can have when the 

user fills out and submits the e-form. They are necessary in order for the receipt to show whether the 

check box was activated or not.  

If you click on the Checked or Unchecked option and look at its Properties window, you will see that 

the word “Checked” or “Unchecked,” respectively, appears as the Text property. The Text property is 

only displayed in the form window, not in the Layout window or browser. 

The contents of the ID property, on the other hand, will appear in the receipt as the user’s answer to 

the check box. The default ID for the Checked option is true and for the Unchecked -option, it is false. 

You can change these expressions if desired. For example, you might want to change “true” and 

“false” to “yes” and “no” or to the equivalent in another language. 

To change the way the answer to a check box is displayed in the receipt 

1. In the ID property for the Checked or Unchecked option, enter the desired text.  

 

Drop Down 

A Drop Down consists of a question, a heading or a statement, followed by a menu that lists the 

possible answers, preferably at least three. 

It is common to make the first answer in the menu a “placeholder” text, such as “Choose here.” 

Thus, the actual answers are not displayed until the user opens the menu. 

Drop downs are easiest to create from the form window. 



 

~ 41 / 71 ~ 

 

 

 

 

 

 

 

A Drop Down as it appears in the form window, after the answers have been typed into the Properties 

windows for the individual Options. 

 

The same Drop Down as it would appear in the browser. 

 

To add another answer to a Drop Down, right-click on the Drop Down element in the form window and 

select Add > Option. 

To create a Drop Down menu 

1. Right-click on the page name in the form window and select  

Add > Drop Down. 

2. In the Properties window for the drop down, type the desired question, heading or 

statement for the menu into the Text property. 

3. In the form window, click on the “+” symbol at the left of the drop down element to display 

its options, which are the posssible answers the user can choose. The first two options will 

have been created for you automatically. 

4. For each additional answer needed, right-click on the drop down element and select Add 

> Option.  

5. For each Option, go to its Properties window and type the text of the desired answer into 

the Text property. 

- Make the first answer a generic placeholder such as “Choose here.” This text will be the one 

that is visible to the user before he or she opens the menu. 

The Text property of the Drop Down element 

itself will become a heading for the Drop 

Down 

 

For each possible answer, create an -Option 

and type the text of the answer into its Text 

property. Make the first answer a general 

phrase that can act as a placeholder. 
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Radio Button 

Radio buttons provide mutually exclusive answers to a question. In other words, only one answer 

can be activated at a time. If you need a set of non-mutually exclusive answers, use check boxes. 

Radio buttons appear in the user’s browser as a series of buttons, each with an accom-pany-ing 

text. In the form window, the texts are structured as -Options under a single Radio Button element. 

Radio buttons are easiest to create from the form window. 

 

To add an answer, right-click on the Radio Button element in the form -window and select Add > Option. 

Each Option will appear to the user as a separate button with an answer.  

 

 

 

 

 

 

 

 

 

 

 

 

 

The same set of radio buttons as it would appear in the browser. 

To create a set of Radio Buttons 

1. Right-click on the page name in the form window and select  

Add > Radio Button. 

2. In the Properties window for the radio button, type the text of the question to be answered 

into the Text property. 

3. Click on the “+” symbol at the left of the radio button element to display its options, which 

are the posssible answers the user can choose. The first two options will have been created 

for you automatically. 

4. For each additional answer needed, right-click on the drop down element and select Add 

> Option.  

5. For each Option, go to its Properties window and type the text of the desired answer into 

the Text property. 

 

The Text property of  

the Radio Button -

element itself will 

become the 

question to be 

answered  

 

For each possible 

answer, create an -

Option and type  

the text of the 

 answer into its  

Text property.  

 

A set of radio buttons as it appears in the Layout window. 
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Text Area and Text Field 

Form Designer’s two types of text entry fields are the elements you will use the most. These are the 

parts of the layout where users can freely type in information. 

A Text Field lets the user enter a single line of information. Often this will only be a single word or 

number. 

A Text Area lets the user enter a longer amount of text. 

When you create a Text Area or Text Field, its Text property becomes a heading for the field (also 

referred to as the field’s label). You can use this text to tell users what kind of information to enter. 

Each text area or text field also has an Internal ID property. The Internal ID appears inside the 

element in the Layout window to help you identify the field, but is not shown in the user’s browser. 

The automatically generated Internal ID should not normally be changed. 

Both TextArea and TextFields have the possibility of computating inside  the element. This possibility 

is found in the Properties window under ‘Compute Field’ 

This possibility lets you compute different elements values added by the user and display it in 

another field. E.g.  autocompute user input and display it in a field for the user to see.  

 

 

 

 

 

 

 

 

 

 

 

The same Text Field as it would appear in the browser. 

 

A Text Area as it appears in the Layout window. 

The Text Field’s Text 

property will become 

a heading for the field.  

 

The Text Field’s Internal 

ID property is shown in 

the Layout window to 

help you identify the 

field, but is not 

displayed in the 

browser.  

 

A Text Field as it appears in the Layout window. 
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The same Text Area as it would appear in the browser. 

 

To create a Text Field for entering a single line of text 

1. Drag a Text Field from the Toolbox into the Layout window, or right-click on the page name 

in the form window and select Add > Text Field. 

2. In the Properties window, type the desired heading or name for the text field into the Text 

property. 

To create a Text Area for entering multiple lines of text 

1. Drag a Text Area from the Toolbox into the Layout window, or right-click on the page name 

in the form window and select Add > Text Area. 

2. In the Properties window, type the desired heading or name for the text area into the Text 

property. 

 To use ‘Compute Field’ for autocomputation 

1. Use ‘Copy Show Only When ID’ from the fields you want to computate and add it to 

‘Compute Field’ property of the field you want to sisplay the result.  

 

2. Add  the type of computation symbol you want to use( -,+,*, /) after the ID in ‘Compute 

Field’ 

3.  Add the next ‘Show Only when ID’ of the next TextField you want to use in the calculation. 

Continue as many times as you want.  

 

 

 

Add the 

computation in 

the Compute 

Field of the 

TextField or 

TextArea that you 

want to display 

the result.  
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File Element 

The File Element is used to give the user he possibilities to attach files or present the possibility for file 

download. 

The Properties of the File Element gives the possibilities to decide size, height, file types etc.  

 

Properties for the File Attachment element 

 

To create a File 

1. Drag a File from the Toolbox into the Layout window, or right-click on the page name in the 

form window and select Add > File. 

Determine allowed file 

types 

 

Decide Max size 

 

 

 

This is how ‘Compute Field’ 

looks in the browser. The Last 

field is the one using the 

‘Compute Field’ option and 

thereby displaying the sum of 

the two previous fields.  

Determine allowed file 

types 

 

Decide Max size 
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2. The File element has a standard Text it displays. Other options could be to add Description 

or an explanatory BodyText 

3. The max size of the file can be restricted by changing the size in the property ‘Maximum File 

Size’ 

4. The types of files that will be accepted can be decided in the property ’Accepted File 

Types’, this is done by adding the file extension names of the accepted files, e.g. .pdf, .docx 

etc.  

 

  

 

This is how the File-element looks in the browser before upload 

 

When the user clicks the File element this window pops-up and the user can now add the files the 

want.  

 

Window that pops-up when user clicks the File element.  
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After uploading the file it is possible to remove it again or to access it via clicking on the file name. 

 

This is how the File-element looks like after uploading a file 

 

File Attachment 

File Attachment is used to attach files in older versions, it has some of the same principles as the File 

element, but more fields that needs to be filled.  

  

Properties for the File Attachment element 

 

To create a File Attachment 

5. Drag a File Attachment from the Toolbox into the Layout window, or right-click on the page 

name in the form window and select Add > File Attachment 

6. The File Attachment element has a standard Text it dispays, It is possible to costumize it by 

setting the property ‘user Deafult Text‘ to false 

7. The File Attachment can be displayed in three different ways:  

a. Inline 

b. Popup 

c. Window 

      The option used is inline, therefore the other options will not be discussed 

8. The max size of the file can be restricted by changing the size in the property ‘Maximum File 

Size’ Typical size is 5120 

9. The height of the file can be adjusted by adding the required height in the ‘Height’ 

property.  

10. The types of files that will be accepted can be decided in the property’Accepted File 

Types’, this is done by adding the file extension names of the accepted files, e.g. .pdf, .docx 

etc.  

 

Determine allowed file 

types 

 

Decide height 

 

Decide Max file size 

 

Decide whether or not 

to display the default 

text or your own text 

added in the text field 
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The file Attachment takes a lot of space in the browser window, and it is advicable not to add it to 

a Group element, since it has it own borders.  

 

 

This is how File Attachment looks in the browser 

A pop up window as seen in File section pops up when the user clicks the ‘Browse..’ button.  

 

 

Divider 

A Divider is a horizontal line that splits the page into sections. 

Dividers can be very useful for creating an overview by visually separating questions or s-ections 

from each other. 

In the browser, a divider is displayed as a thin dashed line. 

 

 

Divider separating to sets of information, as it appears in the Layout window. 
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In the browser, a Divider appears as a thin dashed line. 

To create a Divider 

11. Drag a Divider from the Toolbox into the Layout window, or right-click on the page name in 

the form window and select Add > Divider. 

Placeholder Text 

Placeholder text is used to display a message or hint as to the field’s pupose. The text is displayed 

inside the textbox it’s self and disappears when the field has contains data or the user starts typing. 

An example placeholder text for a First Name field would be “Please enter your first name”. In Error! R

eference source not found. the placeholder feature is shown. 

 

The field ’First name’ contains a Placeholder text, the field ’Middle name’ does not 

Annotation 

The Annotation form element allows users to add notes to a field on the form but not change 

already added notes. 

The element is added to the page like other element types. It is possible to modify the size and to 

placement in the Layout Editor. 
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Adding an annotation at design time 

 

       

Modifying the layout of the annotation element in the Layout Editor 

 

 

Annotation comment after adding a comment 

 

Help Text 

Help texts are intended for providing information that only some users may want to access. This 

may be because they are in doubt about how to fill out a field, because they belong to a group 

with specific needs, etc. 
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A Help Text is represented by a link that the user clicks on in order to bring up the help text itself. This 

makes it easier for users who do not need help to ignore the extra material and move quickly 

through the question-naire. 

In the Layout window, the text of the link is displayed in italics and the help text itself in normal text. In 

the user’s browser, the link will appear with standard link typography (blue and underlined), and 

the help text will initially be hidden. 

 

 

 

 

 

 

 

 

 

The same Help Text as it would appear in the browser, after the link has been clicked on. 

 

To create a Help Text with supplementary information 

1. Drag a Help Text from the Toolbox into the Layout window, or right-click on the page name 

in the form window and select Add > Help Text. 

2. In the Properties window for the help text, type the desired text for the link into the Help Link 

Text property. This is the text that will appear to the user and will indicate that help is 

available if he or she clicks on the link. 

3. Type the help text itself into the Help Text property. 

 

HTML 

When you enter text directly in the Properties window, Form Designer only lets you use a few basic HTML 

tags. With an HTML element, you can use any HTML tags you want to – for example, to create a bulleted list 

like this one. 

To create a text that includes HTML code 

1. Drag an HTML element from the Toolbox into the Layout window, or right-click on the page 

name in the form window and select Add > HTML. 

This text is taken 

from the Help Link 

Text -property. 

 

This text is taken 

from the Help Text 

-property. 

 
A Help Text as it appears in the Layout window. 

 

In the Properties window 

for the Help Text, type in 

the desired texts for the 

link (under Help Link Text) 

and for the Help Text 

itself. 
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2. In the Properties window, click on the “...“ symbol in the HTML property. This opens an HTML 

editor in which you can enter the code you need. 

3. Click on OK to save the text you entered and close the HTML editor. 

 

 

Click on the “...” symbol in the HTML element’s HTML property to open an HTML editor. 

 

Iframe 

An IFrame is used for displaying an external web page directly in your workflow. The page can 

come from any location. 

If you just want a link that users can click on to jump to another web page, use a Link element 

instead.. 

 To include a web page by using an IFrame 

1. Drag an IFrame from the Toolbox into the Layout window, or right-click on the page name in 

the form window and select Add > IFrame. 

2. In the Properties window, enter the URL of the desired web page as the URL property. 

- The easiest and safest way to do this is to copy the URL from your browser and paste it directly 

into the Properties window. 

In the HTML editor, you can 

enter whatever code you 

need. 
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- You can, of course, also type the URL in. 

 

Enter the URL of the desired web page in the URL property of the IFrame element. 

 

             

You can easily display an external web page directly in your workflow by using an IFrame. Unlike a static 

screen shot, the IFrame shown above has functional scroll bars, allow-ing users to view the entire contents of 

the inserted web page 

 

Link 

The Link element lets you create a link to another web page. The page is displayed when the user 

clicks on the link. 

If you want the page to be an integral part of your workflow, use an IFrame element instead. 

 

Links are useful for directing users to supplementary information. In the browser, a Link is displayed with 

standard link formatting. 
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To create a link to an external web page 

1. Drag a Link from the Toolbox into the Layout window, or right-click on the page name in the 

form window and select Add > Link. 

2. In the Properties window, type the desired text for the link into the Link Text property. 

3. Enter the URL of the desired web page as the URL property. 

- The easiest and safest way to do this is to copy the URL from your browser and paste it directly 

into the Properties window. 

- You can, of course, also type the URL in. 

4. For the Open Mode property, select NewWindow if you want the web page to open in a 

separate window (recommended) or Self if you want it to open in your workflow’s window. 

 

 

Enter the URL of the desired web page in the URL property of the Link element. Use the Open Mode 

property to specify whether you want the external web page to open in a separate window 

(recommended) or directly in your workflow’s window. 

 

Picture 

You can add images to your layout by using the Picture element. 

To add an image to your form, use a Picture element. Right click the Page, choose Add and select Picture. 

 

The Property grid for the Picture element look like this: 
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In the Property grid, enter the URL of the desired image in the Picture element’s Image URL property.  

Note that all pictures must be located in the public folder of your Process Platform server and that you 

should use a relative URL that starts with /public/ i.e. /public/myImage.png. 

 

To make an image available for use in your workflows 

1. First make sure the image has the desired size and format, because these cannot be edited 

in Process Designer. 

2. Manually copy and paste the image into the public folder of your Process Platform server. 

- The path to the public folder is: C:\FileRepository\public\ or C:\instances\[instance 

name]\FileRepository\public where [instance name] is the name of the Process Plaform 

instance. 

- If you want to set up image folders or subfolders with other names to systematize your images, 

put the new folders inside the public folder. 

To add an image to the layout 

1. Drag a Picture element from the Toolbox into the Layout window, or  

right-click on the page name in the form window and select  

Add > Picture. 

2. In the Picture element’s Properties window, type the URL of the desired -image into the 

Image URL property. 

- Use a relative URL, i.e., one that starts with /public and contains the  

rest of the path to the desired image. For example, if the image is called handshake.gif and is 

located in a subfolder called companypictures, its relative URL will be: 

/public/companypictures/handshake.gif  

- Remember to include the slash before public. 
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Date Selector Extender 

A date selector is a small icon that looks like a calendar page. When the icon is clicked, an 

interactive calendar is displayed in which the user can click on a date. The chosen date is 

automatically transferred to the text field that the date selector refers to. 

The date selector is a handy and popular feature for users, so we recommend using it whenever 

possible. It will also ensure that all dates entered in the text field have a consistent format 

(determined by the Windows operating system for your area). 

To create a date selector, you drag a Date Selector Extender from the Toolbox into the Layout 

window and then use properties to connect it to the relevant text field. 

 

 

 

 

 

 

 

 

 

 

 

Set the text field’s Type property to Date. 

In the Layout window, the Date Selector 

Extender looks like this. It should be 

placed just to the right of the text field it 

refers to. 

 

A Date Selector Extender is 

represented in the browser by a small 

calendar icon. When the user clicks 

on the icon, an interactive calendar 

is displayed. 
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Then attach the Date Selector Extender to the text field by selecting the relevant field from the menu in the 

Date Selector Extender’s Attach to element property. 

 To attach a Date Selector Extender to a Text Field 

1. If the text field does not already exist, drag a Text Field element from the Toolbox into the 

Layout window, or right-click on the page name in the form window and select Add > Text 

Field. 

2. In the Properties window for the Text Field, set the Type property to Date. 

3. Drag a Date Selector Extender from the Toolbox into the Layout window and place it just to 

the right of the text field. 

4. In the Properties window for the Date Selector Extender, use the menu in the Attach to 

element property to select the relevant text field. 

Description Extender 

In Form Designer, a Description is a mouse-over text that is displayed when the cursor is held over an 

element. A small blue information icon next to the element alerts users to the fact that a description 

is available. The description is an integral part of the element it describes. Its text is taken from the 

Description property for that element. 

You can choose to have an element’s description text visible all the time, rather than as a mouse-

over, by using a Description Extender. The advantage of using a Description Extender instead of a 

Body Text is that the text is part of the element it describes and will move with it, while a Body Text is 

an independent element. 

 

 
To create a Description that is visible all the time, start by entering the text of the Description in the relevant 

element’s Description property and setting the Show Icons property to False. 
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Drag a Description Extender into the Layout window and place it where you want the text to be displayed. 

 

For the Description Extender’s Attach to element property, select the relevant element from the menu. 

 

In the Layout window and browser, the Description text will now appear as an integral part of the page, 

instead of being represented by an information icon. 

 To create a Description that is visible all the time 

1. In the Properties window for the element, type the desired text into the Description property. 

2. Set the Show Icon Placeholder property to False. 

3. Drag a Description Extender from the Toolbox into the Layout window and place it where 

you want the text you entered in step 1 to be displayed. 

4. In the Properties window for the Description Extender, use the menu in the Attach to 

element property to select the relevant element. 

Label Extender 

Many elements in Form Designer consist of two parts, for example, a check box and its associated 

text, or a text field and its associated heading or name. 

The text string associated with an element is called its label.  

If you delete a label from the layout and then realize that you want to display it after all, you can 

recreate it by using a Label Extender.  
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Drag a Label Extender into the Layout window and place it where you want it to be displayed in the 

browser. 

 

Attach the new label to the relevant element by selecting the element from the menu in the Label 

Extender’s Attach to element property. 

To replace a label that was deleted 

1. Drag a Label Extender from the Toolbox into the Layout window and place it where you 

want the text to be displayed. 

2. In the Properties window for the Label Extender, use the menu in the Attach to element 

property to select the relevant element. 
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Modifying layouts in Form Designer 
Once you have created the elements you need, you may want to resize them or move them 

around. This chapter explains the basics of working with layout in eForm -Designer. For additional 

tips concerning the Layout window, see “The Layout window” in Part A of the “Tutorial and Basic 

Information” chapter. 

The layout grid 

The Layout window has a grid to help you keep elements in alignment. When you move or resize 

elements, they snap to the grid. 

The default position for elements 

In Form Designer, each element inserted via the form window is placed directly under the existing 

elements and at the left-hand edge of the page.  

The reason for this is that studies of web behavior show that most users orient them-selves on the 

page by skimming down the left-hand margin to get a quick overview. Often, they do not read 

more than a few words per line. 

Although you can place elements anywhere you want them, taking this typical user behavior into 

account will help people fill out your e-forms quickly and efficiently. There are, however, cases 

(such as address fields) where it makes sense to group -elements horizontally across the page. See 

also “Moving an element” below. 

Adding an element 

You can add new elements to a layout in two ways: 

 By using the right-click menu in the form window. 

- In the Layout window, the new element will be placed directly under the existing elements 

and aligned with the left margin. 

 By dragging an element from the Toolbox directly into the desired location in the Layout 

window. 

- In the form hierarchy, the element will be placed at the bottom of the page or group you 

dragged it to. 

Synchronizing the order of elements in the form and layout 

The data structure of the elements in a Form Designer form is defined by their placement in the 

form hierarchy. Moving elements around in the Layout window will change the appearance of the 

e-form in the browser, but it will not affect the order in which the elements are displayed in form 

data or on the receipt unless you make the corresponding changes in the form window. Similarly, 

changing the order of existing elements in the form hierarchy will not change their placement in 

the Layout window. 
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Form Designer’s default width for labels may mean that you have to expand some of them manually in the 

Layout window to be able to see all of the text. 

 

 

 

 

 

 

 

 

 

 

To move or delete an element together with its description and/or label, start by clicking on the element 

itself. 

 

 

 

 

 

 

 

 

 

 

 

To move or delete only the description or label, without moving the element it refers to, start by clicking on 

the description or label.  
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To keep the two views synchronized, be sure that changes are made in both windows. 

 Ctrl+U moves an element up in the form hierarchy. 

 Ctrl+D moves an element down in the form hierarchy. 

  An element can be dragged into a different group or page with the mouse. 

Default widths for labels and other texts 

For certain elements (text fields, text areas, check boxes, drop downs, radio buttons and help 

texts), the Layout window shows both the element itself (whose name in the case of text fields and 

text areas corresponds to the Internal ID property in the ele-ment’s Properties window) and its label 

(whose name corresponds to the Text property in the Properties window). 

Form Designer assigns a default width to labels. The width is the same as that of a standard text 

field, which is the most common element you will be using in your forms. Similarly, when you create 

text in the form of a heading, body text, or description, the element initially has a standard width. 

If the text of an element or label is too long to fit into the available width, it will be wrapped to form 

additional lines in the browser, so no text is lost. But in the Layout window, it will appear cut off, You 

can easily expand the available width or height by clicking on the item and dragging its handles 

with the mouse. This will change the item’s size both in the browser and the Layout window. 

Note that, in general, it is a good idea to keep label texts as short as possible. 

Moving an element 

Use the Layout window to move elements into the desired positions. You can also move elements 

out of the way temporarily while you work with other parts of the layout. 

 To move an element, click on it and then either place the cursor in the center of the 

element and drag it, or use the arrow keys on your keyboard. 

 If you click on the element itself, any related label or description will move with it. 

 If you click on the element’s label or description, you can move the label or description 

without moving the element. The label or description will still be attached to the element 

and will move with it if you later move the element. 

 For best results, let the grid help you place elements directly under each other or with 

maximum one blank line between them.  

 When placing elements next to each other in the same line, leave no space between 

them. Form Designer will automatically create a little space. 

 For maximum readability, place labels above the text fields, text areas or other elements 

they refer to (default), rather than to the left of the element. 
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You may need to change the size of an element in the Layout window to make its whole text visible. 

Multiple texts (or other elements) can be resized together if they are in the same group or at the root level 

of the same page. Check that all the desired elements have been selected, and then drag any one of 

them with the mouse. 

 

If you accidentally delete a label, you can create a new one. Drag a Label Extender in from the Toolbox 

and place it as desired. Then select the relevant element from the menu in the Label Extender’s -Attach to 

Element property. 

 

 

One way to select multiple elements before moving, resizing or deleting them is to drag a selection box 

around them. Before carrying out the desired operation, check that only the desired elements have been 

marked! 
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Changing the size of an element 

 To resize an element, click on it and then either drag its square white handles with the 

mouse or hold down the shift key and use the arrow keys. 

Deleting an element 

 To delete an element, click on it and then press the Delete key on your keyboard. 

- If you click on the element itself, any related labels or descriptions will be removed along with 

it. 

- If you click on the element’s label or description, you can delete the label or description 

without removing the element itself. 

 If you accidentally delete a label, you can create a new one. Drag a Label Extender from 

the Toolbox into the Layout window. Then attach it to the element by selecting the 

element’s name in the label extender’s Attach to Element property. 

Acting on multiple elements at the same time 

You can select multiple elements in the Layout or form window and then move, resize or delete 

them as a group, provided that the elements are at the same level of the hierarchy (i.e., in the 

same group or directly on the same page). There are several ways to do this: 

In the Layout window 

 Click on one element, hold down the shift or Ctrl key and click on the other -desired -

elements. 

 Use the mouse to drag a selection box around the desired elements. 

In the form window 

 To select elements that are next to each other in the hierarchy, click on the first element, 

hold down the shift key and either click on the desired last element or use the up or down 

arrow key to mark additional elements. 

 To combine elements freely, click on the first element, hold down the Ctrl key and click on 

each of the other desired elements. 

- When a node in the hierarchy is marked, you can expand or collapse it by -using the right 

and left arrow keys, respectively. This corresponds to clicking on the plus symbol at the left of 

the node. 

- If you hold down the Ctrl key, you can use the up and down arrow keys to scroll through the 

form window while selecting. This is particularly useful if the page or group is too long to be 

displayed in the window at a single  time. 
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Examples of text written in “layers” 

  

Help Link 

 Help Text that 

appears 

when the link 

is activated 

 

Heading 

Question with 

answers 

Statement 

 

Supplemen-

tary text 

with link to 

more 

”Must Read” 

text style 
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Maximizing user-friendliness 
By following some generally accepted guidelines for writing texts and laying out pages, you can 

greatly increase the accessibility of your workflow solutions to users. This chapter summarizes some 

of the most effective techniques, based on the principle of “layering.” 

Write in layers 

When people use the Internet, they tend to read texts in fragments and are more likely to skim and 

skip around than when they read printed material. For this reason, you should organize your texts in 

“layers.” 

Writing in layers means that you let users dig more or less deeply into the text, depending on their 

interests and needs. To achieve this, you split the text into chunks, each of which has its own 

function and some of which may only be revealed if the user specifically activates them. This allows 

users to focus on what is relevant for them. 

Writing in layers helps you build workflows that simultaneously meet the needs of different kinds of 

users. For example: 

 Quick users, who fill in the e-form quickly and expertly. 

 Thorough users, who read everything on the screen. 

 Curious users, who tend to seek additional information. 

Layer 1: Headings structure the page 

What to use: Heading; Body Text with the “Emphasize” style or “Heading 2” style 

Headings are an important part of the structure of your page. They serve as atten-tion-getters and 

navigational landmarks for the reader. By splitting text and graphics into manageable chunks, 

headings make it easier for users to skim the page. 

 Use a Heading element if you want the heading to be included in the receipt. 

 Use a Body Text element with the Emphasize style if you only want to create a visual landmark 

on the page and don’t want the heading to be included in the receipt. The type size is a 

little smaller than a Heading. 

 Use a Body Text with the Heading 2 style to split a long text passage up with subheadings. The 

type size is a little smaller than the Emphasize style. 

Layer 2: Questions with answers or statements ease interaction 

What to use: Heading; Text; Option for Drop Down or Radio Button 

Well written questions and answers go a long way towards helping users fill out an e•form without 

difficulty. Some users will be able to navigate exclusively via these elements, without needing 

additional explanations. 
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Examples of Help Link Texts as they would appear in the browser. Note how the text at the bottom specifies 

the group of users for which it is relevant. 

 

 

Typical Description (mouse-over) texts as they would appear in the browser. 

 

  

A typical explanatory text as it would appear in the browser. 
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Layer 3: Help and advice eliminate doubt 

What to use: Body Text; Help Text; Description (mouse-over text) 

Different users need different levels of information and assistance. By anticipating their needs, you 

can minimize the amount of effort people will need to fill out your forms. 

Help Texts 

A Help Text is placed next to a question and is represented in the first instance by a link the user can 

click on. The help text is displayed when the user clicks on the link and disappears when he or she 

clicks on the link again. 

Help texts are most relevant when the answer to a question is not obvious. If there are several help 

texts, place them together at the end of the question.  

The text of the link itself should be as clear and helpful as possible. Instead of a gene-ric text like 

“Help” or “Read more,” write something related to the specific situation, such as “What 

requirements must you fulfill in order to be eligible”. If the supplementary information is only relevant 

for certain users, mention the target group in the text. 

Descriptions (mouse-over texts) 

In Form Designer, a Description is a mouse-over text: a text that appears when the cursor is held 

over an element and disappears when the cursor is moved away. Descriptions are typically used to 

explain how users should fill out a field. Usually, this means a short example, short explanation or a 

description of the required format. The text in a Description should be kept very short, since the text 

will disappear if the user moves the mouse away from the “information” icon. 

Explanatory texts (“open” Descriptions) 

Unlike mouse-over texts, which only appear when the user activates them with the mouse, 

explanatory texts are displayed as an integral part of the -layout. 

Explanatory texts can be used for several purposes: 

 To explain the reporting process to the user, especially in long reports. This is particularly 

relevant if the user has to submit multiple types of information on multiple pages. 

 To inform users that they will need to have certain documents or information available while 

filling out the form.  

 To give users information that will help them answer a question or fill out a field. If the 

information is only relevant for certain users, mention the target group in the text. 
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A typical note as it would appear in the browser. 

 

 

A “demystifying” text explains to the user why certain information is needed or how it will be used. Its 

purpose is often to reassure skeptical users that their data will not be misused. 

 

 

Use Form Designer’s “Must Read” style only for important messages that must not be overlooked. 

 

 

Example of a supplementary text with a link to even more information. 
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Remember, NB and Note 

If you need to draw the user’s attention to something in connection with a question, you can add a 

short text starting with “Remember!”, “NB!” or “Note:” 

You may want to apply the Emphasize style to make the note stand out visually from the rest of the 

text.  

Texts that demystify or reassure 

In some cases you may want to explain why specific information is needed or what will or will not 

be done with it. This may, for example, be useful to reassure users that their personal data will not 

be passed on to third parties.  

“Must Read” texts 

Must Read Text is a standard typography choice in Form Designer that can be applied via the Style 

property of a Body Text element. The Must Read Text style is visually very different from the other 

available styles and should only be used for important warnings. Otherwise, the effect will be lost.  

Layer 4: Supplementary texts with links to further reading 

What to use: Body Text; Link 

Some users are curious about more information, and some seek additional explanations before 

answering an item, especially if they are worried about submitting personal information. Other users 

do not want to be forced to read large amounts of text before moving to the next step. By using 

supplementary texts, you can fulfill the needs of both groups. 

Supplementary texts provide additional information, and may include links to external texts. They 

are typically used for information such as regulations and legal explanations that only some users 

will access, but that can be valuable for them to have. Supplementary texts can easily be ignored 

by users who are not interested in going deeper.  

Since supplementary texts are typically used to learn more about a topic before answer-ing an 

item on a form, they should be placed very close to the elements they refer to, and after any other 

texts related to the element. 

To have the external text appear in a separate window when the user clicks on the link, set the 

link’s Open Mode property to New Window. This will make it easier for the user to navigate back to the e-

form after reading the supplementary information. 
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